0

emacs version 26.3 OSX 10.14.1 Following is my .init file. It is present at ~/.emacs.d

(require 'package)

(add-to-list 'package-archives
             '("melpa" . "http://melpa.org/packages/") t)

(package-initialize)
(add-to-list 'load-path "~/.emacs.d/elpa/") ;; on may 01 2020
(require 'popup) ;; dependancy 
(require 'auto-complete)

(setq backup-directory-alist `(("." . "~/.saves"))) ;; this work totally fine

In my home directory ~/.emacs.d/elpa is present

How do I enable that auto-complete works?

I don't know if the path for elpa is being read although I've added it to the list.

  • 1
  • thank you. It doesn't help. It isn't enabled, let alone global or, mode specific issue. :). – Death Metal May 2 at 2:24
  • 2
    Looks like you need to add, at least, (ac-config-default). Probably you have it enabled but you don't have any sources to provide completion. – Muihlinn May 2 at 8:20
  • @Muihlinn ac-config-default isn't helping. – Death Metal May 2 at 17:12
  • 1
    You need to turn on (global-auto-complete-mode 1) or its equivalent. Another option is to add a specific auto-complete setup function to the init hook of the mode you are interested in using it with. More info is available in its docs. – InHarmsWay May 2 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.