more tests

I've now confirmed this behavior in Emacs 24.5 on a linux machine. Basically, if there is an @ symbol in one of the parent directories, gud will hang.

the first update

I've actually discovered what the issue is, but don't know how to fix it.

My current laptop is a company issued laptop and my username/home directory is defined like so: /Users/[email protected]/

If the python file I'm debugging with gud/pdb is under that path, pdb fails to launch properly. Any other path, and it launches fine.

So I'm guessing that @ symbol is the source of the current problems.

Is there any way to modify some variable or gud so that it can work with that @ symbol in the path?

the original post

I'm not even sure how to even begin to debug or diagnose this issue. And searching turns up nothing.

Basically, M-x pdb will create a buffer and display Current directory is XYZ and then just stop there.

I've used M-x pdb successfully many times in the past but I recently switched to MacOS Catalina and also updated emacs to 26.3. I installed python 3.7.7 via homebrew.

Here's what I've tried so far

  • disable .emacs
  • use homebrew emacs
  • use the emacs at emacsformacosx.com
  • update python from 3.7.3 to 3.7.7
  • remove all python packages

None of them work. And it's not a pdb issue because I can enter pdb fine from any regular shell. I just can't get pdb through gud.

Is there a solution? Or is there a way I can at least debug the gud/pdb launch process?

  • Is it the new catlalina privacy permissions? emacs.stackexchange.com/questions/53026/…
    – al0
    May 7, 2020 at 3:04
  • @al0 Apparently not. I've updated the question with more info.
    – JasonMond
    May 7, 2020 at 3:09
  • Any idea whether this is specific to Emacs 26? If not, i.e., if this is not really a question about Emacs 26 (versus other releases), then please consider removing that tag.
    – Drew
    May 7, 2020 at 15:10
  • @Drew I tested it out with Emacs 25 and still the same problem. So tag is removed.
    – JasonMond
    May 7, 2020 at 17:38
  • I observe the same behavior with emacs 26.3 on ubuntu 18.04
    – matteol
    May 8, 2020 at 16:36


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.