0

I typically run gnuemacs using MacPorts. However, I have a friend who does not have admin on his managed mac, so I want to build for him a full release of emacs that will run out of his home directory. He does not have admin rights.

I tried downloading the sources for all of these versions:

-rw-r--r--  1 xf  staff  20403483 Feb 17  2005 emacs-21.4a.tar.gz
-rw-r--r--  1 xf  staff  39587396 Sep  5  2008 emacs-22.3.tar.gz
-rw-r--r--  1 xf  staff  47721193 Jan 28  2012 emacs-23.4.tar.gz
-rw-r--r--  1 xf  staff  39759804 Apr 10  2015 emacs-24.5.tar.xz
-rw-r--r--  1 xf  staff  44415140 Aug 28  2019 emacs-26.3.tar.xz

None of them build properly. I always end up with some kind of Killed error, like:

emacs-26.3 % make
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C lib all
make[1]: Nothing to be done for `all'.
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C lib-src all
make[1]: Nothing to be done for `all'.
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C src VCSWITNESS='' all
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C ../admin/charsets all
make[2]: Nothing to be done for `all'.
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C ../admin/unidata charscript.el
make[2]: Nothing to be done for `charscript.el'.
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C ../admin/unidata all EMACS="../../src/bootstrap-emacs"
  ELC      uvs.elc
/bin/sh: line 1: 37172 Killed: 9               "../../src/bootstrap-emacs" -batch --no-site-file --no-site-lisp -f batch-byte-compile uvs.el
make[2]: *** [uvs.elc] Error 137
make[1]: *** [../lisp/international/charprop.el] Error 2
make: *** [src] Error 2
emacs-26.3 %

So I tried using brew. It built emacs, but I get the same problem:

% brew/bin/emacs
zsh: killed     brew/bin/emacs %

So what's the proper way to build this?

  • Wild guess: increase your stack limit using ulimit -s – rpluim May 15 at 11:44
0

I build emacs from github source : https://github.com/emacs-mirror/emacs

Autogen.sh
./configure
Make 
Make install

That compile without any error

Best regards

capture of emacs about

| improve this answer | |
  • 1
    Building Emacs on macOS has several issues. For instance using gcc causes problems. Usually, the Apple's clang should be used. Building with NS support is likely to cause AppKit/AppKit.h not found error too. – Romario May 16 at 12:00
  • Thanks, @Romario. If you could post the dependencies, I can accept your answer. – vy32 May 16 at 13:42
  • strange, the only dependency I have to use is makeinfo, texinfo and gnutls – olopost May 16 at 13:51
  • @vy32 Before Mac OS X 10.7 (Lion), building Emacs on 10.6 and 10.5 was a breeze because the CoreFoundation, AppKit, etc were working with the Emacs' build script out of the box and the X Window Framework came built in. On newer versions of macOS, first try building a headless Emacs i.e. (assuming your default CC is GCC) CC=/usr/bin/clang ./configure --without-ns --without-x --with-gnutls=no then try with the NS support. – Romario May 16 at 16:42
  • I actually don’t want NS support! I want just terminal mode. Very old school... – vy32 May 16 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.