3

This might be a fairly stupid question but I simply can't figure it out.

I've been trying to install doom-modeline for spacemacs: https://seagle0128.github.io/doom-modeline/#install

I've added the use-package stuff to the configuration file like this:

...
   ;; configuration in `dotspacemacs/user-config'.
   dotspacemacs-additional-packages '((use-package doom-modeline
                                        :ensure t
                                        :init (doom-modeline-mode 1))
                                      (use-package all-the-icons))
   ;; A list of packages that cannot be updated.
   dotspacemacs-frozen-packages '()

...

Then I restarted spacemacs and it did install something. However, the modeline didn't change:

my modeline

It doesn't look like in the screenshots here: https://seagle0128.github.io/doom-modeline/#screenshots

Do I somehow have to activate it or something?

1
  • Did you try recompiling the spaceline? M-x spaceline-compile Commented Sep 30, 2020 at 2:02

2 Answers 2

1

Disclaimer: I did not find a way to integrate it into the Spacemacs intended use of packages.

Solution

Adding this snippet to my dotspacemacs/user-config:

(use-package doom-modeline
:ensure t
:init (doom-modeline-mode 1)
:config
;; Enable flashing mode-line on errors
(doom-themes-visual-bell-config)

;; Corrects (and improves) org-mode's native fontification.
(doom-themes-org-config)
)

Drawback

  • The packages doom-modelineis going to be delete and reinstalled at every Emacs startup when dotspacemacs-install-packages 'used-only) this option is set ( which I would recommend to avoid garbage ).

It seems Spacemacs does not support constructs like this(use-package <package> :ensure t).

Things tried

  • Putting doom-modeline into dotspacemacs-additional-packages.
    • Including trying to add the configuration block I put into the dotspacemacs/user-config section.
    • Result: Configuration is not applied.
  • Writing a custom layer and initializing doom-modeline in this layer.
    • Result: Configuration is not applied.

References

0

i've been all over the place with this , the issue with doom-modeline is that it gets removed as orphan caue if you require or use-package it duplicates it , look at the spacemacs-modeling layer..grep for doom-modeline. The trick is this tell spacemacs modeline to use doom-modeline:

dotspacemacs-mode-line-theme '(doom :separator-scale 1.5)

and then just simply

(doom-modeline-mode 1) in (defun dotspacemacs/user-config ()

and it will never get removed again. here's he doc:

   ;; Set the theme for the Spaceline. Supported themes are `spacemacs',
   ;; `all-the-icons', `custom', `doom', `vim-powerline' and `vanilla'. The
   ;; first three are spaceline themes. `doom' is the doom-emacs mode-line.
   ;; `vanilla' is default Emacs mode-line. `custom' is a user defined themes,
   ;; refer to the DOCUMENTATION.org for more info on how to create your own
   ;; spaceline theme. Value can be a symbol or list with additional properties.
   ;; (default '(spacemacs :separator wave :separator-scale 1.5))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.