0

I just installed Helm and it looks really cool. However, I don't understand how to use dired anymore.

I'd usually C-x d to see my directory, then I could do operations like add or delete files. Now I get a helm dired buffer, which is super fast, but when I scroll to the file I'm looking for and type 'd', it's just doing auto-complete, not in a mode where I can do file operations.

What should I do instead?

My init.el has the minimal, vanilla helm additions:

(require 'helm-config)

(global-set-key (kbd "M-x") #'helm-M-x)
(global-set-key (kbd "C-x r b") #'helm-filtered-bookmarks)
(global-set-key (kbd "C-x C-f") #'helm-find-files)
(helm-mode 1)
  • You have not entered dired, you're still inside the completing interface, you need to pick a file/directory to enter dired. When helm-mode is enabled, the default Emacs completing interface is replaced by helm's, hit RET to choose one file/dir. – xuchunyang May 21 at 7:08
  • But when I pick a folder, it just keeps going deeper and deeper into sub directories, not giving me a dired buffer. – Mittenchops May 21 at 13:37
  • It doesn't, I mean RET, though you can goto subdir using C-j. – xuchunyang May 21 at 14:30
  • That's not what RET does in my case, honest. It just takes me to the sub-folder. The only commands I have for helm were the above, so should be vanilla. – Mittenchops May 22 at 0:58
  • I don't think that's expected. C-x d RET, and you're in dired, with or without helm-mode. – xuchunyang May 22 at 1:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.