1

The situation is:

I install pdf-tools manually and load it with the following snippet:

(use-package pdf-tools
   :pin manual
   :load-path "my/load/path/to/the/git/repo/lisp"
   :config
    ....stuff...)

Everything works fine, and I am happy with this setup. But....

The problem is:

I cannot install any package which depends on pdf-tools, since the package manager does not recognize it as being installed. Thus, M-x package-list-packages lists me quite a bunch of packages which are "incompatible" because they depend on pdf-tools. But it is there!

How can I convince the package manager to install these packages?

EDIT:

I've tried the answer given to this very similar question and added pdf-tools to package--builtin-versions. Still not available for the package manager, the other package depending on it is still blocked.

4
  • If the package manager doesn't recognise it as being installed then (at least by default) it would install it as a dependency.
    – phils
    May 23, 2020 at 22:39
  • E.g. If I tell the package manager to install pdf-view-restore and pdf-tools isn't already installed, then they will both be installed.
    – phils
    May 23, 2020 at 22:41
  • I think "incompatible" would more likely indicate that the package manager does recognise that pdf-tools is installed, and that the other packages depend upon a newer version of it.
    – phils
    May 23, 2020 at 22:49
  • I see. The reasoning seems to be right, but I cannot verify that the versions are the problem. pdf-tools are version 1.0, the requirement for the 'incompatible' packages is > 0.8 or 0.7, depending on the package. So versions do not seem to be the problem. My problem is: How do I tell the package manager to consider pdf-tools & friends as installed? It seems that I should hack package-alist, but I am not really willing to do it. May 24, 2020 at 12:38

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.