0

I am trying to install org-ref package but getting error

package-compute-transaction: Package 'emacs-25.1' is unavailable.

I searched Stack overflow, Stack Exchange Emacs, and github. I've found many solutions like this but isn't working for me.

I am using Emacs 25.1 in Ubuntu 16.4.

Edit: I am using Emacs 24.5.1 version.

I was able to install org-ref earlier but need to reinstall as it got corrupted.

2
  • first of all try M-x emacs-version before installing it, you won't be the first nor the last who had several emacs versions installed in several paths and trying to install the wrong version.
    – Muihlinn
    May 28 '20 at 7:26
  • I have only one emacs versions and it is 24.5.1 May 28 '20 at 8:17
1

You need to upgrade your emacs to at least Emacs 25.1.

I'm not sure if each Ubuntu LTS provides updated stable packages beyond the point they released the distro, emacs26 now, but if not you can either compile it yourself or look for a suitable ppa as Kevin Kelley's

1
  • I managed to do it with my 24.1 version itself. Thanks. May 28 '20 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.