0

I newbee in Emacs, and trying to set up emacs. Well, I've written a init.el file and except few things always work properly. But in -nw mode cursor doesn't work (blink not working), tabs doesn't work (2 tabs always, and I can't do few tabs), cursor-color doesn't work and etc. What Do I do wrong?

init.el:

(require 'package) ;; package.el

;; repositories
(setq package-archives '(("gnu" . "http://elpa.gnu.org/packages/")
                         ("melpa" . "http://melpa.org/packages/")
                         ("org" . "http://orgmode.org/elpa/")
             ("marmalade" . "http://marmalade-repo.org/packages/")
             ))

(package-initialize)

(load-theme 'dracula t)

;;;;;;;;;;;;;;;;;;;;;;WINDOW SIZE;;;;;;;;;;;;;;;;;;;;;;;;;;;
(add-to-list 'default-frame-alist '(height . 40))
(add-to-list 'default-frame-alist '(width . 120))
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;


;;;;;;;;;;;;;;;;;;;;;;SPLASH SCREEN;;;;;;;;;;;;;;;;;;;;;;;;;
(setq inhibit-startup-screen t) ;; turn off
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;;;;;;;;;;;;;;;;;;;;;;TAB BEHAVIOR;;;;;;;;;;;;;;;;;;;;;;;;;;
(setq-default tab-width 4)
(setq-default indent-tabs-mode nil)
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;;;;;;;;;;;;;;;;;;;;;CURSOR SETTINGS;;;;;;;;;;;;;;;;;;;;;;;;
(save-place-mode 1) ;; save cursor place in file
(set-default 'cursor-type 'box) ;; cursor type underscore
(set-cursor-color "#ffffff")
(blink-cursor-mode 1)
;;(setq visible-cursor nil)
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;


(setq frame-title-format "emacs") ;;

(menu-bar-mode -1) ;; hide menu-bar

(tool-bar-mode -1) ;; hide tool-bar

(scroll-bar-mode -1) ;; hide-scroll bar

(column-number-mode) ;; column numbers show in bottom

(show-paren-mode)

(global-hl-line-mode)

(winner-mode t)

(windmove-default-keybindings)

(global-set-key (kbd "M-x") 'smex)
(global-set-key (kbd "C-c C-c M-x") 'execute-extended-command)

(global-display-line-numbers-mode)

(ac-config-default)

(custom-set-variables
 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 '(package-selected-packages (quote (auto-complete smex dracula-theme))))
(custom-set-faces
 ;; custom-set-faces was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 )
  • 1
    The question is too broad, and so risks being deleted. Please narrow things down to one specific question (pose other specific questions separately). You can narrow your init file by commenting out 1/2, then 3/4, 7/8, etc. of it, to check each thing you want to ask about. You can use command comment-region to comment out a selection of lines (the region). And with C-u first you can use it to uncomment a selection of lines. – Drew Jun 6 at 1:50
  • 1
    In a terminal, the cursor is determined by the terminal. See C-h i g (emacs)Cursor Display – phils Jun 6 at 11:12
  • Similarly cursor color in a terminal is controlled by the terminal’s settings. I don’t know why tabs should differ though (they do not for me), although note that in a terminal, some complex key chords are not transmitted correctly. – InHarmsWay Jun 8 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.