While I'm trying to access any of the org-agenda options or commands! I always get this error Symbol’s value as variable is void: org-priority-highest and the list shows nothing even though I've set org-agenda-files correctly

3 Answers 3


The current name for the highest priority value is org-highest-priority instead of org-priority-highest. They changed the names in January 2020 in this commit. An alias was added for the old name, but there was a bug in the way it was done.

This bug appears to be in 9.3.6 and fixed in 9.3.7. Try updating your org-mode.

  • I use straight.el as the package manger so I got latest commit in the repo!
    – Aadhish
    Commented Jun 9, 2020 at 18:13
  • 2
    Maybe you have a mixed install? There are issues upgrading org-mode when it's already loaded. What if you uninstall and reinstall?
    – erikstokes
    Commented Jun 9, 2020 at 18:15
  • I tried and uninstalling and reinstalling but the problem persists
    – Aadhish
    Commented Jun 9, 2020 at 18:35
  • In that case I would first restart with emacs -q and do the minimum to reproduce the error. Use M-x toggle-debug-on-error to get a backtrace to the point in the code generating the error. If the error is in org-mode you can submit a bug report
    – erikstokes
    Commented Jun 9, 2020 at 18:48
  • On the contrary: org-priority-highest is the official name going forwards; the other one is an alias for backward compatibility. The title of the commit is "Rename org-x-priority functions and variables to org-priority-x".
    – NickD
    Commented Apr 10, 2021 at 4:17

This error occurred for me when using straight.el to load various org packages. Org being a dependency leads straight to cloning a current version of it into its local repo. Using agenda then created the same error message of Symbol’s value as variable is void: org-priority-highest.

In my case(Emacs 27.1, Org 9.3), a simple solution was to tell straight.el to use Emacs' standard built-in org version instead by using the :type built-in directive. I placed the following before declaring any other org-related packages:

(straight-use-package '(org :type built-in))


It's an problem of straight.el see here. I solved using a solution given by one user in the github isssue.

Thanks for answering and helping me!

  • whats your org load strategy in straight now? its still not working for me,
    – RichieHH
    Commented Dec 3, 2020 at 6:26
  • can you please add the solution to the content of your answer?
    – Asaf
    Commented Apr 8, 2021 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.