0

I tried to highlight lines that exceed 80 columns using whitespace-mode. Eventually didn't like that idea and removed that from my init.el. However, the whitespaces are shown as . and line ends are $ in the files that I edit. How can I get rid of that. I tried adding the following to the init.el file. But that doesn't work between restarted session. (whitespace-mode 0). Every time I source the init.el by load-file it works but not otherwise. I am a newbie emacs user and getting my way around with emacs and lisp. Could any one suggest me how to troubleshoot this issue?

  • 1
    Did you try searching for whitespace in your init file? You may still have a setting in there that causes problems. Also, check the value of the variable whitespace-global-modes? If non-nil, try to find where it is set and change it to nil. – NickD Jun 15 at 18:44
  • What @NickD said (but it's global-whitespace-mode). – Drew Jun 15 at 22:41
  • I have looked every line of my init.el file but whitespace-mode was nowhere. However, upon rebooting my system, I start to see my regular files without whitespace-mode characters. Could someone care to advice/explain how/why is this? – Bussller Jun 16 at 2:13
0

whitespace-mode is local to a buffer.

If you put (whitespace-mode 0) in your init file it affects only the buffer than happens to be current at the time that sexp is evaluated. Don't do that.

Instead, bisect your init file to find out just which part of it is enabling whitespace mode wherever you see it but don't want it. And look for global-whitespace-mode, which turns it on everywhere.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.