0

I'm trying to compose a link to the describe-package help buffer to the xref package like this:

[[(elisp:(describe-package "xref"))][xref]]

But it can't execute. So I wonder how to pass arguments to an interactive function from within Elisp. I don't believe anyone has asked this question, and after much searching I still couldn't find the answer. I've tried the following forms and none of them worked.

(describe-package "xref")
(call-interactively 'describe-package "xref")
(call-interactively (describe-package "xref"))
(call-interactively (lambda () (interactive) (describe-package '("xref"))))
(command-execute (describe-package "xref"))
(command-execute 'describe-package "xref")
1

According to the docs, describe-package takes a symbol as argument not a string so you need:

(describe-package 'xref)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.