0

I am trying to plot simple examples in org-mode by using gnuplot. But it keeps telling me "Searching for program: No such file or directory, aspell".

I installed gnuplot both to on emacs and on system wide. Also installed gnuplot-mode in emacs.

The table that I am trying to plot is:

#+PLOT: title:"Grades in Physics and Mathematics" ind:2 deps:(3 4) type:2d with:histograms set:"yrange [0:]" set:"xlabel 'Student'" set:"ylabel 'grades'" set:"output './img/gnuplot-grades.png'" set:"terminal png size 600,500"
|---+--------+-------------+---------|
|   | Grades | Mathematics | Physics |
|---+--------+-------------+---------|
| # | Ben    |         9.2 |     9.9 |
| # | Tom    |         6.7 |     7.7 |
| # | Tim    |         7.5 |     6.7 |
| # | Dean   |         8.0 |     7.0 |

I am using org-mode 9.3.7 which came by default. Is the issue related with emacs/org-mode version?

B.R.

2
  • 1
    You must have enabled a spell checker that is configured to use aspell. Two choices: find out where and disable it, or install aspell. – NickD Jul 8 '20 at 13:32
  • Thank you. aspell problem is solved by installing it via os's package manager. But still cannot produce any plots. I checked the gnuplot version on both emacs and system which were different and fixed that. Still,it does not produce any plots. Any suggestion ? – Kadir Gunel Jul 9 '20 at 6:13
2

Check that:

  • gnuplot is installed: just run it from the shell to make sure it's present and if so, just exit out of it (I have version 5 and that worked).
  • gnuplot-mode is installed; checking e.g. with C-h f gnuplot-mode RET should be enough.
  • make sure that there is a subdirectory img under the directory where the Org mode file lives: the options specify set:"output './img/gnuplot-grades.png'" but if the img directory does not exist, this will fail.

With all conditions satisfied, I was able to produce the output file.

If you still have trouble, check your *Messages* buffer for messages like this:

gnuplot-mode 0.6.0 (gnuplot 5.0) -- report bugs with "C-c C-u"

which shows that both gnuplot-mode and gnuplot are installed and what the versions are (my gnuplot mode is old: 0.7.0 is available).

If you see such messages, then there should also be a buffer named*gnuplot* that gnuplot-mode creates and uses to send commands to the underlying gnuplot process. Switch to that buffer and see if any commands failed and what the errors are.

Good luck!

1
  • Thank you again. The problem was in saving settings. – Kadir Gunel Jul 9 '20 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.