0

I had to reinstall emacs and completely redo my config file, but for some reason, some of the custom keybindings that used to work with "move-dup" package from Melpa. Here is what i have:

#+begin_src emacs-lisp 
(require 'move-dup)

(global-set-key (kbd "M-<up>") 'md-move-lines-up)
(global-set-key (kbd "M-<down>") 'md-move-lines-down)
(global-set-key (kbd "C-M-<up>") 'md-duplicate-up)
(global-set-key (kbd "C-M-<down>") 'md-duplicate-down)
#+end_src>

What would stop these from working? EDIT: so this does work, if i enable move-dup-mode, however I can't seem to get it to be enabled on start up, I've tried adding the following but it still doesn't load on startup:

(move-dup-mode 1)

I've also tried:

(global-move-dup-mode 1)

and I've also tried replacing the '1' for a 't' in on each one too, but to no avail. How can I get this to load on startup please?

1

Do you have either a (require 'move-dup) or a use-package declaration for move-dup? If not, that is likely your problem.

3
  • Yes it is in there, I just moved it to the top of the config file just under use melpa part, and then added (global-move-dup 1) up to the top of the page also and it all came to life and now does work. Thanks for your input, I'm going to give you a solved. – iFunction Jul 15 '20 at 9:00
  • 1
    it sounds as though there is an error in your init file and so everything after that is not being loaded. Check the message you get after you open emacs. – Aidan Schofield Jul 15 '20 at 11:18
  • Thank you for the confirmation, this is what I suspected, moving it up worked for me for the moment, and everything else loads fine, so I may well have fixed it by mistake, not ideal, but it all works now. – iFunction Jul 15 '20 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.