2

Here's my Semantic config:

(semantic-mode 1)

So my config probably isn't the issue.

Whenever I try to use Semantic commands in an elisp file, I get the message Buffer was not parsed by Semantic.. So I tried doing semantic-force-refresh and it says, Buffer reparsed. (no errors). But it still throws the "not parsed" error when I try to use a semantic command.

$ emacs -Q --eval "(semantic-mode 1)" has the same issue.

Everything works as intended in c-mode and c++-mode. What gives?

Version info:

CEDET Version:  2.0
            Requested   File        Loaded
  Package       Version     Version     Version
  ----------------------------------------------------------
  cedet:        2.0     nil     ok
  eieio:        1.4     nil     ok
  semantic:     2.2     nil     ok
  srecode:      1.2     nil     Not Loaded
  ede:          1.2     nil     ok

I usually use Emacs in Cygwin:

GNU Emacs 24.4.1 (i686-pc-cygwin) of 2014-10-21 on desktop-new

But I have the same problem on my Arch VPS:

GNU Emacs 24.4.1 (x86_64-unknown-linux-gnu, GTK+ Version 3.14.3) of 2014-10-21 on bitzer.hoetzel.info

EDIT: I discovered that (semantic-active-p) returns nil in elisp buffers. I'm not sure why.

1

I solved this problem by downloading and installing a recent snapshot of CEDET from here: http://www.randomsample.de/cedet-snapshots/

I used this snapshot: cedet_snapshot-rev_8698.tar.gz 29-Dec-2014 21:00 1.5M

I guess the version shipped with this version of Emacs is broken.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.