0

I just buy a new macbook and I want to move my old working env to it. I used emacs-plus@27.0.91 which was installed by homebrew:

d12frosted/emacs-plus/emacs-plus@27: stable 27.0.91, HEAD
/usr/local/Cellar/emacs-plus@27/27.0.91 (4,014 files, 131MB) *
  Built from source on 2020-07-15 at 20:36:39 with: --with-no-titlebar --with-jansson --with-mailutils --with-modern-icon

I cloned my old .emacs.d config repo and it works well from terminal using both -nw, and without -nw.

But when start Emacs from spotlight, Emacs will give me an error message Method 'zsh' is not known/Method 'zsh' is not known/tramp-error: Method 'zsh' is not known, the Emacs window shows the following error, and press any key now will also only triggers this error.

I tried to bug-hunt the init file, but found no error.

Btw, no zsh is found in my .emacs.d, though I am using zsh in terminal. And no settings relative to tramp.

Here is my .emacs.d : https://github.com/cmal/.emacs.d Can you help me out?

enter image description here

enter image description here

8
  • Your error message clearly states that this is a "tramp-error". If you want the author/maintainer of Tramp to have a look at your question, then use a tag that states "tramp" (a tag with "init-file" will not likely get the Tramp maintainer's attention unless he reads all the questions) ; i.e., edit your question and use the relevant tag. Consider editing your question to add your relevant settings that tell "tramp" where your zsh executable is located, and so forth. Maybe your old computer used a different shell file name, and/or maybe it is now in a different location ... – lawlist Jul 17 '20 at 8:33
  • Thanks. I've updated my question. But still not find any relative settings. – cmal Jul 17 '20 at 10:11
  • Thanks to the tag tramp, I've found the question (I'm the Tramp maintainer). Run M-x tramp-cleanup-all-connections, this should fix your issue. – Michael Albinus Jul 17 '20 at 11:28
  • If your question is about not being able to start Emacs from Spotlight, then it can't have anything to do with your init file or Tramp or anything else that takes effect after start-up. Try starting Emacs from Spotlight using emacs -Q (no init file). Please edit your question to remove everything that's not relevant. Thx. – Drew Jul 17 '20 at 17:44
  • @Michael Albinus I've run M-x tramp-cleanup-all-connections , started from spotlight, still has this problem. emacs -Q will work fine. I've NEVER used tramp or have any configurations about tramp on this machine. I've found if I start a emacs frame from hammerspoon using /usr/local/bin/emacsclient -n -c -a "" will also got the zsh error. Is this related to emacs-plus@27.0.91? – cmal Jul 18 '20 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.