1

Usually people want to print some characters and end up having strange squares clearly telling them this character is unknown by their default font and they have no fallback font for it.

My problem is quite the opposite, my current font (Fira Code) actually knows all the characters and seems to not agree with all-icons on some of them.

In my custom.el file I have a function to display some bullets as special characters and I explicitly wrote:

enter image description here

I put screenshots because it looks like StackExchange can't handle these unicode characters:

'(? ? ? ?) 

When I put my cursor on one of these characters and M-x describe-char I get the following answer:

enter image description here

Note that the code for this character is #xe3d0 (and the other three are #xe3d(1/2/4)" so I could write my list like this:

'(#xe3d0 #xe3d1 #xe3d2 #xe3d4)

Anyway, when I restart my emacs to have my prettified bullets:

enter image description here

And even better, if I go back to my customisation file (at least it's coherent):

enter image description here

I tried adding:

(set-fontset-font "fontset-default"
                  '(#xe3d0 . #xe3d4) (font-spec :name "FontAwesome"))

But it didn't change anything.


[EDIT] If I write this list (according to https://en.wikipedia.org/wiki/Enclosed_Alphanumerics):

'(#x2460 #x2461 #x2462 #x2463)

I have the wanted result:

enter image description here

2
  • 2
    Characters 0xE000 through 0xF8FF are reserved for private use. This means that they are not assigned to any purpose by the Unicode standard, and are instead reserved for users and institutions to decide on. Thus they look like whatever you have configured your web browser to display them as, and for me they look like what I've decided to display them as. describe-char will tell you what font Emacs decided to pull glyphs from, it'll be tagged with "display:". You'll also see that the category is Co (Other, Private Use).
    – db48x
    Jul 18 '20 at 18:07
  • Thanks for the information, didn't know that. And that's actually my question, how can I tell emacs that for this range I want it to use FontAwesome? I tried with set-fontset-font but it keeps displaying them with FiraCode
    – Lhooq
    Jul 18 '20 at 18:12
0

Looks like the font I need to use is not "FontAwesome" but "Material Icons" :

(set-fontset-font t '(#xe3d0 . #xe3d4) "Material Icons")

And it works :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.