1

Adding layers existing in the layer section of the .spacemacs documentation results in failed test in the dot-test-results buffer generated after reloading the .spacemacs file (with SPC-f-e-R).

increminated layers were : neotree ;; for filetree

notmuch ;; for emails

parinfer ;; clojure / lisp paren inference

pdf ;; pdf visualisation

prettier

The * spacemacs* welcome screens gets some warnings but couldn't find any other error messages to help debug :

   Warnings:
           - Unknown layer neotree declared in dotfile.      
           - Unknown layer notmuch declared in dotfile.      
           - Unknown layer parinfer declared in dotfile.      
           - Unknown layer pdf declared in dotfile.      
           - Unknown layer prettier declared in dotfile.      
           - package twittering-mode not initialized in layer keyboard-layout, you 
             may consider removing this package from the package list or use the :toggle 
             keyword instead of a `when' form.      
           - package linum not initialized in layer nlinum, you may consider removing 
             this package from the package list or use the :toggle keyword instead of a `when' form.      
           - package linum-relative not initialized in layer nlinum, you may consider
             removing this package from the package list or use the :toggle keyword 
             instead of a `when' form.      
           - More than one init function found for package helm-make. Previous owner was ivy,
             replacing it with layer helm.      
           - More than one init function found for package smex. Previous owner was ivy,
             replacing it with layer smex.      
           - package evil-nerd-commenter not initialized in layer evil-commentary, you may
             consider removing this package from the package list or use the :toggle keyword
             instead of a `when' form.      
           - package vi-tilde-fringe not initialized in layer vim-empty-lines, you may
             consider removing this package from the package list or use the :toggle keyword
             instead of a `when' form.      
           - tern binary not found!     

my config : OS: mac osX Catalina 10.15.5
emacs : GNU Emacs 26.3 (build 1, x86_64-apple-darwin18.5.0, Carbon Version 158 AppKit 1671.4) fetch with brew install emacs-plus@26 IIRW

spacemacs à jour (latest)
271 packages loaded in 18.794s (e:202 r:2 l:18 b:49)

(this seems slow, may be because of spaceline-all-the-icons)

My .spacemacs is still a work in progress and thus not in a github repo yet so I attached a gist link below.

Thanks for any hits on how to get thos layers working.

Best Samusz

.spacemacs file: https://gist.github.com/samusz/2cfb1ced064276be06eee4488cc86788


 


  • I've got the same issue... unfortunately no solution yet? – David McCorrie 2 days ago
0

Found the issue for me... https://github.com/syl20bnr/spacemacs/issues/10840

It seems pdf used to be called pdf-tools. So I changed it to pdf-tools and it seems to work now.


UPDATE: I was previously using the latest master but it looks like master is very old compared to develop. The latest release at the time 0.200 is even older. I've now moved branch to develop and the code seems to match the online documentation a lot better. It looks like the long time between releases has caused the documentation to diverge significantly from the latest release

So this is something else to check if you have this issue. It will hopefully get better when the upcoming 0.300.x is released?

| improve this answer | |
New contributor
David McCorrie is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.