0

the image is self explanatory, I recently switched to doom emacs and I'm still learning.

How can I fix this problem? I tried to switch off anything related to checkers in the init.el file but it doesn't help.

The problem is that rainbow-delimiters is recognizing (0,1] as a "not matching parenthesis" in latex environment, so it is highlighting everything from that point on. Now I really tried to disable the whole package in doom-emacs but I failed. It can easily toggled off with M-x rainbow-delimiters , but I want it disabled by default

  • You can try to see which modes are active with describe-mode and selectively disable them. With non-evil keybindings you can use M-x describe-mode (possibly bound to C-h m, depending on your configuration) – einfeyn496 Aug 2 at 14:23
  • What's the question? What is "this problem" that you want to fix? Are you asking how to not highlight braces (they aren't parentheses, BTW)? So far, the question is unclear, so it risks being deleted. Please try to clarify the question. Thx. – Drew Aug 2 at 16:38
  • If this happened when you switched to Doom Emacs, maybe you should ask this question to the maintainers of Doom Emacs? Are you using a "default" Doom Emacs config, or is it a mix of Domm's and your own? – Stefan Aug 3 at 1:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.