I am running into trouble installing smart-mode-line and ox-hugo. I use M-x list-packages, select package I want with I, and then execute with X.

The error in Messages buffer looks like:

Contacting host: melpa.milkbox.net:80
Parsing tar file...
Warning: premature EOF parsing tar file
package-untar-buffer: Package does not untar cleanly into directory smart-mode-line-20190527.1156/

But, I didn't have a problem updating org package.

I tried this with Emacs 26.3 and 27.1.1 (both from emacsformacosx.com) on macOS.

The problem is similar to one reported here almost a year ago.

Any suggestions please?


I was just now able to install that package, so everything seem fine to me. However, I notice that you've configured Emacs to contact melpa.milkbox.net. That url was replaced with just melpa.org about five years ago. You'll probably want to revise your configuration:

(add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/") t)
  • Terrific! Thank you so much, that solved the problem. I was scraping together my init.el file from various blogs.... lord knows what other dilapidated settings I have. Onward --- and generally upward --- until the next speed bump.
    – midas0441
    Aug 18 '20 at 20:59
  • That's the spirit!
    – db48x
    Aug 18 '20 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.