2

After upgrading to Emacs 27.1, my default font changed to adobe courier. I would like to use Anonymous Pro or Inconsolata, but attempts to change it using M-x customize-face RET default fail. I am at a loss to describe the behavior as it seems to me irregular and I am not sure where to begin. Setting it to Anonymous Pro or Inconsolata, which so far as I can tell are in fact installed on my system and go by those names, causes the font to fall back to a serif font that looks like times. I am using the KDE Font Management utility to see what fonts are installed. Running xfontsel to look at which fonts are installed gives a different list, but entering information from it produces indeterminate effects---the font does change, but I can't tell if it's falling back to courier or a default serif font. So far as I can tell, it usually does make the right change, which I can test for instance if I use etl for the foundry and fixed for the family. The emacs font matches what that font looks like in the xfontsel menu.

So---as should be clear---not sure where to begin troubleshooting.

I'm using Emacs 27.1, on OpenSuse Leap 15.2, KDE.

  • 1
    Emacs 27 switched the font backend to Harfbuzz, so it's possible this is a bug. You might be able to set a frame parameter like (add-to-list 'default-frame-alist '(font-backend . xft)) to go back to non-Harfbuzz font rendering. – amitp Aug 19 '20 at 15:58
0

I found a "solution"---the problem has been fixed, although I don't know why. Maybe this will help someone else experiencing this kind of instability.

Tinkering, I used S-down mouse-1 as instructed at the EmacsWiki Set Fonts page. Emacs crashed when I selected Anonymous Pro. I deleted the desktop on general principle. After I restarted emacs, I could select Anonymous Pro using S-down mouse-1 to change the face in a buffer. Then I could set it persisently as the default face using customize.

  • I've also had had 27 break fonts (e.g. all emoji visible through C-x 8 RET Can you clarify what you mean by "deleted the desktop"? – Webdev Tory Aug 19 '20 at 18:03
  • "Deleted the desktop" is probably too strong. I turned desktop-save-mode off (M-x desktop-save-mode); it's on by default in my setup. – Adam Aug 20 '20 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.