I recently upgraded my Mac to Catalina 10.15.6.

I also upgraded emacs to 27.1. When I try to start it, I get an error: "Emacs" can't be opened because Apple cannot check it for malicious software:

that is cannot check for malicious software

I tried downloading the dmg directly from emacsformacosx.com and installing via brew cask install emacs, which appeared to get it from the same place.

brew install emacs installed 26.3 and would only open it in the terminal, not as a separate app. I know that there used to be a --with-cocoa option, but I could not figure out how to get that to work.

What do I need to do to install emacs on Catalina, such that it works in a separate window rather than in a terminal?


4 Answers 4


Posting what worked for me from here

brew cask reinstall emacs --no-quarantine

  • For some reason, this only worked on my machine with the cask and reinstall swapped around: brew reinstall cask emacs --no-quarantine
    – Dut A.
    Commented Sep 29, 2021 at 7:52
  • brew reinstall homebrew/cask/emacs --no-quarantine worked for me.
    – offby1
    Commented Jan 8, 2022 at 0:32
  • brew cask is no longer a brew command. The correct, updated command is now brew reinstall emacs --no-quarantine --caskas suggested by @Shahbaz Zaidi.
    – kotchwane
    Commented Mar 15, 2022 at 16:27

This should resolve the issue

brew reinstall emacs --no-quarantine --cask

  • It would help to explain that line a bit - just what was changed and why it has the effect it does.
    – Drew
    Commented Feb 25, 2022 at 15:44

I got the same error message, "Emacs" can't be opened because Apple cannot check it for malicious software with Emacs.app v27.2-3 (the most recent version as of this writing), downloaded as disk image from https://emacsformacosx.com/ and installed on macOS Big Sur, Version 11.6.1. To work around this error, I downloaded and installed one of the older versions, Emacs-26.3-universal.dmg. The credit should go to dahanbn, who posted the workaround on Reddit - please upvote there.


Previously I installed it by downloading the dmg. So if you try brew reinstall you'll get:

Error: It seems there is already an App at '/Applications/Emacs.app'

So, get into the Applications folder, delete the Emacs app. And then run brew install instead of reinstall:

brew install emacs --no-quarantine --cask

(I'm running BigSur, the command may be slightly different in other macOS versions)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.