0

I recently upgraded to 27.1 version from 24.5 version. I am trying to install org-roam. When I use package-install RET org-roam, I am getting the following error.

Library is file /usr/share/emacs/27.0.50/lisp/emacs-lisp/package.elc
next-line: End of buffer [25 times]
package-compute-transaction: Package ‘emacs-26.1’ is unavailable

The main error is Package 'emacs-26.1' is unavailable.

I searched and found a couple of answers here and here but not clear.

The /usr/share/emacs/ directory is having three sub directories namely 24.4, 24.5, 27.0.50.

I don't know whether I have to change the load path of my package.el file or is there any other option.

1
  • As per @Drew's advice, I removed the answer and put it here as a comment. Thanks, Drew. Using straight.el solves the problem, but the actual problem lies with org-roam. – Sreekumar R Feb 20 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.