1

Is it possible to set org-mode to show the headlines inside emacs without bold font?

My emacs:

* Headline 1 <-- This is bolded

a paragraph <-- This is not bolded

** Headline 2 <-- This is also bolded

I would like to have:

* Headline 1 <-- Not bolded

a paragraph <-- Not bolded

** Headline 2 <-- Not bolded

Note: I have found a set-up that eliminates all fontification from the headlines:

(setq org-level-color-stars-only t)

but I would like to keep colors and just eliminate boldness from the headlines at all levels.

Hopefully my question is understandable.

Thx!

2
  • When I open the recently released public version of Emacs 27 -- without any user-configuration (aka emacs -Q) -- and I go to the *scratch* buffer and type M-x org-mode and then on an empty line I type * TODO [#A] testing one two three, the only bold that I see is the word TODO. If you do that same test -- without any user-configuration, aka emacs -Q, do you get the same result as me? Perhaps you are using a theme that you installed which adds a bold spec to the org-level-1 et seq. faces? – lawlist Aug 29 '20 at 1:42
  • Using the same test in the comment above, I place my cursor anywhere on the words testing one two three and type C-u C-x = and then look in the *Help* buffer that opens up, I see the face at issue is org-level-1 face. If I place my cursor on the words org-level-1 in the *Help* buffer and press the enter key, I see that the face is inherited from the outline-1 face. If I place my cursor on the words outline-1 in the *Help* buffer and press the enter key, I see that the face is inherited from the font-lock-function-name-face face. Repeat process, foreground is Blue1. – lawlist Aug 29 '20 at 1:52
2

@lawlist nailed it. It is a configuration of the theme. I am currently using solarized.

I kinda of fixed my issue setting

(setq solarized-use-variable-pitch nil)

as it is suggested on the README. But I would like to point out that in my case, it removed all boldness rendering from the org file. For me it is enough, hence the answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.