1

I am using the windows version of emacs that includes AuTeX and ESS from Vincent Goulet. I was using an older version of this packaging with a couple different versions of R. I recently installed the new version of R (4.0.2) and am attempting to connect it to emacs. I have added the directory that contains the R version 4.0.2 to my path and also added the folder that contains the 3 different version of R that are installed on my machine. When I open a .R file and open an instance of R it opens an R version of 4.0.2. However, when I go to the ESS menu and try to start a new process (ESS>Start Process>Other>) the options that I see are R-3.4.4-32bit, R-3.4.4-64bit, R-3.5.1-32bit, R-3.5.1-64bit. Similarly, if I try to complete M-x R the options do not include the R-4.0.2 version. Also when I tried M-x R-newest I got the error: Symbol's function definition is void R-newest. I have tried again to run M-x R-newest but now it stats [no match].

I was previously using an older release version Vincent Goulet's emacs but updated it while attempting to fix this issue. The current version I am using is emacs 26.3 with ESS 18.10.2. I have tried changing the PATH variable in numerous ways to include/exclude the directory of the R verions for the older versions. I tried looking in the lisp and changing some custom variables in my .emacs file to no avail, such as

(custom-set-variables
 '(ess-rterm-version-paths
   (quote
    ("C:/Program Files/R/R-4.0.2/bin/x64/Rterm.exe" "C:/Program Files/R/R-4.0.2/bin/i386/Rterm.exe" "C:/Program Files/R/R-3.5.1/bin/i386/Rterm.exe" "C:/Program Files/R/R-3.4.4/bin/i386/Rterm.exe" "C:/Program Files/R/R-3.5.1/bin/x64/Rterm.exe" "C:/Program Files/R/R-3.4.4/bin/x64/Rterm.exe")))
)

How do I get ESS to recognize R-4.0.2 (both 32bit and 64bit) and add it to the list of available processes?

New contributor
user3653085 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

Check the value of ess-r-runner-prefixes. Until recently, it did not include R-4. You can customize it yourself, or if you install the latest/current version of ESS the default value should work.

See the responses to this email on the mailing list for more details:

https://stat.ethz.ch/pipermail/ess-help/2020-April/012729.html

UPDATE

This is a known issue, and Vincent Goulet's latest release (as of September 17, 2020) includes a fix.

| improve this answer | |
  • When I try to check the value of ess-r-runner-prefixes it says no match. I do have an ess-r-created-runners though. It showed the 2 older version of R. I've tried reinstalling ess from melpa commit 0728c6fdf8e13f10ee50b27fb3f39e7c229f05b1 and now ess-r-created-runners is not matching. – user3653085 Sep 16 at 21:45
  • ess-r-runner-prefixes wasn't in ESS 18.10.2. That version was released two years ago, before R 4 was available. You can get a more recent ESS by installing it from MELPA – Tyler 2 days ago
  • @user3653085 this problem is fixed in the Vincent's latest release! – Tyler 2 days ago
  • Awesome! Thanks for leting me know it works like a charm now – user3653085 2 days ago

Your Answer

user3653085 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.