1

I'm using emacs over tramp to edit a project inside a vm on my local machine. It has something like this:

ssh:vm:~/projects/project/.dir-locals.el
ssh:vm:~/projects/project/src/tests/file-i'm-editing.f90

On my local machine I have .dir-locals.el setup properly, but when I'm editing files on the vm, it doesn't seem to use the .dir-locals.el file. Is this expected or should it be using that file?

I have edited the file on the vm to have the correct paths.

3
enable-remote-dir-locals is a variable defined in ‘files.el’.
Its value is nil

  You can customize this variable.

This variable was introduced, or its default value was changed, in
version 24.3 of Emacs.
  Probably introduced at or before Emacs version 24.3.

Documentation:
Non-nil means dir-local variables will be applied to remote files.

n.b. I believe this is disabled by default as a performance measure, to reduce the overheads of working with remote files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.