2

When I switch buffers using helm, the first option is prefixed with [?] and tries to create a buffer named exactly what I typed. I find that this is the right behavior for creating files, but it is annoying for switching buffers. I'd prefer the first choice be one of the existing buffers. Can I make the [?] appear as the last option in the list instead?

enter image description here

enter image description here

  • 2
    You should use helm-mini or helm-buffers-list (similar to helm-mini but use ido-virtual-buffers. Don't use stock switch-to-buffer in helm-mode. Here is a demo. – Tu Do Jan 6 '15 at 15:02
  • helm-buffers-list was exactly what I wanted. Thanks! – wdkrnls Jan 7 '15 at 15:47
1

As pointed out by Tu Do, helm-buffers-list places the option to create a new buffer as the last choice. So it's just a matter of using it instead of switch-to-buffer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.