0

I'm using Doom Emacs on macOS, if it matters.

Essentially, I'd like to disable the pylint checker entirely when editing Python files. I don't use pylint, and I don't have it installed in my Pyenv environments; it gives me false positives.

But I'm not a skilled Emacs user, and I can't figure out how to disable it. I have this in my config:

(use-package! flycheck
  :config
  (add-to-list 'flycheck-disabled-checkers 'python-pylint)
  (add-hook 'pyhon-mode-local-vars-hook
          (lambda ()
            (when (flycheck-may-enable-checker 'python-flake8)
              (flycheck-select-checker 'python-flake8)))))

But it doesn't seem to matter -- every time I open a Python file, it tries to start up pylint.

1
  • Have you checked flycheck-disabled-checkers explicitily to make sure it includes python-pylint? What happens if you do the (add-to-list 'flycheck-disabled-checkers 'python-pylint) by hand? Does flycheck skip it then? – NickD Oct 1 '20 at 22:12
1

This is working for me:

(use-package flycheck
  :config
  (setq-default flycheck-disabled-checkers '(python-pylint)))
2
  • 2
    please add some reasoning to make your response more complete. – Muihlinn Jan 29 at 19:51
  • 1
    Yes, please let readers know how it answers the question - what it does. – Drew Jan 29 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.