1

Context

Hey, I've discovered semantic and how useful it is when writing coding, it provides some handy features. I'm mostly using it for C/C++ programming, although there's a bug that kept on showing, and it's bothering me a lot. I've debugged it for several days now, but as you may tell, still no use. Now the issue is with semantic-idle-summary-function.

Suppose I have the following

(setq semantic-idle-summary-function 'semantic-format-tag-summarize-with-file)
(setq semantic-idle-scheduler-queue 
      '(semantic-idle-completions-idle-function 
          semantic-idle-summary-idle-function 
          semantic-idle-local-symbol-highlight-idle-function 
          semantic-idle-breadcrumbs-idle-function))

I don't think I messed the configuration somehow, since I've tried resetting and trying different summary configurations, but as you can guess with no use.

Please feel free to correct me if I'm wrong in something about semantic or idle (I'm don't know much).

Issue

The issue is when I'm over some expression like

using func = std::function<bool(int)>;
      ^           

This error showed up in *Messages* when loading the corresponding .[hc]pp files and keep on showing up in the minibuffer as long as I'm over the tag.

Idle Service Error semantic-idle-summary-idle-function: "#<buffer xargs.hpp> - Wrong type argument: listp, \"void\""

Now everything is working fine, until something breaks and semantics stop showing any idle summary until I restart Emacs again. Although the error just disappears when I'm on something else like a function prototype.

However, I figured out that the bug is triggered even comments, since if a symbol was in the comment it is summarized as if it was syntax. Does anybody know what the wrong or how to fix it? Thanks!!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.