0

I recently encountered this problem:

Emacs org-mode agenda filter doesn't work. :(

And sure enough, on macOS, I find that org-agenda-files is nil. The answer suggests setting the variable to a static list of filenames in .emacs.

However, on my Linux machine, this is unnecessary. I find that org-agenda-files will always be a list of whatever Org files I have open. I'm using the same .emacs on macOS as I am on Linux.

I have Emacs 26.2 on the Mac, and 26.1 on Linux.

How do I get org-mode on the Mac to auto-populate the org-agenda-files list like it does on Linux?

  • 1
    By duplicating the setting of org-agenda-files on your Linux box? There is a setting somewhere: do C-h v org-agenda-files on your Linux box and see what it says. And read the doc string of that variable: there are quite a few different ways to set it with different semantics. – NickD Oct 13 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.