0

While in web-mode, when I type {{ emacs will add }} to the end, and when I press SPC it will then add another }} to the end with a space either side and one extra space to the right, so it looks like this {{ | }}}}. Apparently there are two commands that are working together to "help" me, I want to disable one of them.

I am trying to find the source of the problem, so is there a way I can view the commands that caused this issue so I can fix it myself?

I am using Doom Emacs

1

Type C-hl to run view-lossage which will show you the last several keystrokes, and which commands they are bound to in the current buffer (which might not be the same as the commands they were bound to in the buffer which was active when they keys were typed -- only the keystrokes themselves are actually recorded).

n.b. Older Emacsen will display only the key sequences.

2
  • Thanks, I had come across that before, it appears to be self-insert-command, but I am at a loss of where to go from there. Another question might be in order then. Oct 14 '20 at 11:11
  • electric-pair-mode (and electric-pair-local-mode) are the in-built options for auto-paired parens. I'm not sure what web-mode will be doing.
    – phils
    Oct 14 '20 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.