0

I am relatively new to Emacs and was going through this document to learn more about org-mode: https://orgmode.org/worg/org-tutorials/org4beginners.html

I couldn't help but notice that the following shortcuts were not working:

  • C-c / t – show TODOs in current document

    • My emacs frame says C-c t is undefined
  • Imagine that you have a large document, with scattered all over the document TODO entries, C-c C-v will show only your current TODOs, and folding the rest away.

    • My emacs frame says C-c C-v- is displayed in echo area, as if it is awaiting another keystoke (? Control sequence?)
  • Unfortunately, both will show just empty lists (you can try if you want). So just press C-g (the Emacs version of escape). Next we will add 1.org as agenda file, using C-c [. Now if you go to the agenda menu (C-c a), and press t you get a list off all your TODO items.

    • In my emacs frame, although C-c [ does add the file to the list of agendas, the C-c a shortcut says C-c a is undefined in the echo area. Obviously the t keystroke does nothing as well in this case.

What can I do to solve my problems? I installed Emacs using these instructions and I am using WSL2 on Windows with the Ubuntu-20.04 distro. I followed the instructions exactly in the tutorial.

Here is my ~/.emacs file if it is necessary:

;; -*- mode: elisp -*-

;; Disable the splash screen (to enable it agin, replace the t with 0)
(setq inhibit-splash-screen t)

;; Enable transient mark mode
(transient-mark-mode 1)

;;;;Org mode configuration
;; Enable Org mode
(require 'org)
;; Make Org mode work with files ending in .org
;; (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
;; The above is the default in recent emacsen
(custom-set-variables
 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 '(org-agenda-files '("~/test/emacs/1.org" "~/test/emacs/2.org")))
(custom-set-faces
 ;; custom-set-faces was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 )
  • Those keybindings are only defined in Org mode, not everywhere: you need to be in an Org mode document. When you visit a file, e.g. foo.org, make sure that the mode line says (Org) - if that's the case, then C-c / t et al. should work. C-c C-v however is not defined anywhere that I can find, so it may be that that tutorial is outdated. – NickD Oct 15 at 13:38
  • For C-c a, that is a suggested keybinding and you have to do that for yourself: it is not done by Org mode. See Activation in the Org mode manual. – NickD Oct 15 at 13:44
  • 1
    @NickD Yes, I am in org mode (the mode line says (Org)). Everything else is working fine except these. Maybe I am misinterpreting the C-c / t thing.. Ah! This does actually mean you have to press the / key between the C-c and t, I thought that was perhaps a typo. OK ya, most of it seems to work now. Is there an equivalent to C-c C-v in what is Org mode today? – herophant Oct 15 at 17:11
  • C-c C-v is a prefix indeed. Do C-h m in an Org mode buffer and explore! – NickD Oct 20 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.