1

I've been playing around with Emacs for the first time this week, and I've been having some issues with the color scheme. This post was prompted by getting some weird when using helm. I've also noticed that when I load emacs without any init file, it opens up with a dark background instead of a white background that everyone else mentions.

Here's a picture of Emacs loaded without any init file:

enter image description here

And here is how helm looks.

enter image description here

At this stage, I have not loaded any theme. I checked this with the disable-theme command, and no theme was loaded.

Adding a theme does not fix issues either. Here it is with the deeper blue theme loaded

enter image description here

Again, I ensured that only a single theme was loaded using the disable-theme command.

I saw this thread from the past, which presented with similar issues as I have, however he was able to change versions

Some context:

  • OS: Linux Mint 19.2 Tina
  • Windows Manager: i3 version 4.18.2
  • Emacs Version: GNU Emacs 27.1

I saw this thread from the past, which presented with similar issues as I have, however he was able to change versions which fixed the issue. I tried purging all emacs stuff on my system and deleting my local ~/.emacs.d directory (there was no ~/.emacs file -- everything was in ~/.emacs.d/init.el), and downgraded to version 26. Unfortunately, the color issues with helm were not fixed. My emacs background remained dark when loaded without any init file as well.

I should probably mention that at one point I had installed Doom Emacs, and my color schemes with both Helm and Ivy working as expected then (though the default background was still dark). This was also using GNU Emacs 27.1. However, I decided to go back to vanilla emacs to try and learn how to configure the software myself, and have been getting issues

The entirety of my init.el is posted below. I generate my system's color scheme using wal, and run XRDB on a colors.Xresources file that it creates. I've attached that below as well, just in case it is the cause of any problems. Any suggestions would be appreciated.

init.el

(package-initialize)
(require 'package)
(require 'use-package)

(add-to-list 'package-archives '("gnu" . "http://elpa.gnu.org/packages/"))
(add-to-list 'package-archives '("melpa" . "http://stable.melpa.org/packages/"))

(use-package evil
         :ensure t)
(evil-mode 1)

(use-package org
         :ensure t)

(use-package helm
  :ensure t)
(require 'helm-config)

(setq helm-split-window-in-side-p t
      helm-move-to-line-cycle-in-source t)

(helm-mode 1)

;; List Buffers ( Emacs way )
(global-set-key (kbd "C-x b") 'helm-buffers-list)

;; List buffers ( Vim way )
(define-key evil-ex-map "b" 'helm-buffers-list)

;; Bookmarks menu
(global-set-key (kbd "C-x r b") 'helm-bookmarks)

;; Finding files with Helm
(global-set-key (kbd "C-x C-f") 'helm-find-files)
(define-key evil-normal-state-map (kbd "SPC .") 'helm-find-files)

(global-set-key (kbd "M-x") 'helm-M-x)

(global-set-key (kbd "M-y") 'helm-show-kill-ring)

;backups settings
(setq backup-directory-alist `(("." . "~/.emacs.d/.backups")))
(setq backup-by-copying t)

colors.Xresources

urxvt*font: xft:DejaVu Sans Mono:size=9

! X colors.
! Generated by 'wal'
*foreground:        #e3e1de
*background:        #1f1b1d
*.foreground:       #e3e1de
*.background:       #1f1b1d
URxvt*foreground:   #e3e1de
XTerm*foreground:   #e3e1de
UXTerm*foreground:  #e3e1de
URxvt*background:   [90]#1f1b1d
XTerm*background:   #1f1b1d
UXTerm*background:  #1f1b1d
URxvt*cursorColor:  #e3e1de
XTerm*cursorColor:  #e3e1de
UXTerm*cursorColor: #e3e1de
URxvt*borderColor:  [90]#1f1b1d

! Colors 0-15.
*.color0: #1f1b1d
*color0:  #1f1b1d
*.color1: #BF9A71
*color1:  #BF9A71
*.color2: #697991
*color2:  #697991
*.color3: #AB9C93
*color3:  #AB9C93
*.color4: #D1AC9E
*color4:  #D1AC9E
*.color5: #D4C4B7
*color5:  #D4C4B7
*.color6: #B3C8C8
*color6:  #B3C8C8
*.color7: #e3e1de
*color7:  #e3e1de
*.color8: #9e9d9b
*color8:  #9e9d9b
*.color9: #BF9A71
*color9:  #BF9A71
*.color10: #697991
*color10:  #697991
*.color11: #AB9C93
*color11:  #AB9C93
*.color12: #D1AC9E
*color12:  #D1AC9E
*.color13: #D4C4B7
*color13:  #D4C4B7
*.color14: #B3C8C8
*color14:  #B3C8C8
*.color15: #e3e1de
*color15:  #e3e1de

! Black color that will not be affected by bold highlighting.
*.color66: #1f1b1d
*color66:  #1f1b1d

! Xclock colors.
XClock*foreground: #e3e1de
XClock*background: #1f1b1d
XClock*majorColor:  rgba:e3/e1/de/ff
XClock*minorColor:  rgba:e3/e1/de/ff
XClock*hourColor:   rgba:e3/e1/de/ff
XClock*minuteColor: rgba:e3/e1/de/ff
XClock*secondColor: rgba:e3/e1/de/ff

! Set depth to make transparency work.
URxvt*depth: 32
urxvt.scrollBar: false
2
  • On macOS, my Emacs -Q starts with a "dark theme" (actually there is no theme) as well, it seems a feature to me, since when I switch to light theme in the system settings, Emacs turns to light automatically. On GNU/Linux, since GUI Emacs is a GTK application, maybe related to GTK dark theme?
    – xuchunyang
    Oct 20 '20 at 17:48
  • The issue with the default dark background was coming from my Xresources file: *foreground: #e3e1de *background: #1f1b1d *.foreground: #e3e1de *.background: #1f1b1d Removing those lines fixed that portion for me, but the weird helm colors persist. Even if I load a blank Xresources file, the weird helm colors persist. I presume that's not how it's supposed to look, anyway. Thanks. Oct 20 '20 at 17:56
0

Ok, so there were, I think, two separate issues.

One, to fix the default, no-init-script background color I removed the following lines from my Xresources file:

*foreground:        #e3e1de
*background:        #1f1b1d
*.foreground:       #e3e1de
*.background:       #1f1b1d

To fix the color issues in helm, I downloaded the doom themes. Using a doom theme seemed to fix the issues with the weird colors in helm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.