1

How does eshell resolve its PATH?

If I run my top in eshell on my local machine, it opens a new buffer and shows the output of the command in it. However, if I do the same on an eshell run on a remote machine I get:

/ssh:remote:/home/me/ $ top
----- in *top* bugger -----
..: 1: exec: /ssh:remote:/bin/top: not found

Process /ssh:remote:/bin/top exited abnormally with code 127

I certainly do have top on the remote machine and it is in /bin/top.

4
  • 1
    I can reproduce the problem in Emacs' master branch, aka Emacs 28.0.50. I recommend you to write a bug report, M-x report-emacs-bug. Oct 29, 2020 at 10:30
  • @MichaelAlbinus I did so. Although I use Emacs 27.1, it is kinda stable version. It might well be that I'm just doing something wrong...
    – yujaiyu
    Oct 29, 2020 at 15:32
  • 1
    I've seen, thank you. Since I can reproduce the problem, I wouldn't believe that you've done something wrong. Oct 29, 2020 at 17:55
  • I can reproduce with a freshly built Emacs from the master branch right now. I started with emacs -Q, connected to remote machine, eshell, then top with exactly the same error. It seems to happen with eshell-visual-commands, but not with other commands on the remote machine. I get the same error output if I do M-x term and then enter the full TRAMP path to top on the remote machine. Jun 8, 2022 at 19:23

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.