Is there a way to browse a flash USB drive formatted in Mac OS Extended (Journaled, Encrypted) using Emacs 27 Dired?

After I Enter a password to unlock the disk “XYZ”. I can browse the folders and the files just fine using Finder, but I prefer to operate with Emacs rather than Finder.

When I try to look (through Emacs Dired-mode) at the Volume, I get Listing directory failed but ‘access-file’ worked.

I am the owner of the volume:

drwxrwxr-x   7 calaf    staff  306 Nov 18 12:14 XYZ

and so this does not seem to be a case of dr-xr-xr-x permissions (where the files are readable if their names and paths are, but a directory listing isn't).


This appears to be not related to the disk formatting, but to whether a folder is backed up to iCloud.

It also appears to be related to a recent upgrade to Catalina, rather than to Emacs 27 (or, for that matter, to using sudo port install gnupg2 rather than port install gnupg for Emacs ps-ccrypt). But I don't have either Desktop or Documents connected to iCloud, and yet the same issue arises with both.

Can you clarify what this is all about?

1 Answer 1


What if you give Emacs full disk access in System Preferences → Security & Privacy → Files and Folders—if Emacs is listed there. Apparently no one can add applications to this list, the +/- buttons are greyed out for everyone?

Files and Folders pane

If Emacs is not listed there, you could try navigating to, for example, ~/Downloads in dired and see if macOS prompts you to allow access.

Failing that, or if you want Emacs to have access to everything, you can try granting Emacs "Full Disk Access" there in Security & Privacy.

  • Emacs already has "Full Disk Access", yet when I try to read ~/Desktop I get "Listing directory failed but ‘access-file’ worked".
    – Calaf
    Commented Nov 20, 2020 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.