0

When flycheck finds too many warnings that do not fit in the mini-buffer, it opens up a window on a buffer named Warnings that looks something like this:

Warning (flycheck): Syntax checker python-pylint reported too many errors (665) and is disabled.
Use ‘M-x customize-variable RET flycheck-checker-error-threshold’ to
change the threshold or ‘C-u C-c ! x’ to re-enable the checker.
Warning (flycheck): Syntax checker python-pylint reported too many errors (665) and is disabled.
Use ‘M-x customize-variable RET flycheck-checker-error-threshold’ to
change the threshold or ‘C-u C-c ! x’ to re-enable the checker.
Warning (flycheck): Syntax checker python-pylint reported too many errors (659) and is disabled.
Use ‘M-x customize-variable RET flycheck-checker-error-threshold’ to
change the threshold or ‘C-u C-c ! x’ to re-enable the checker.
Warning (flycheck): Syntax checker python-pylint reported too many errors (667) and is disabled.
Use ‘M-x customize-variable RET flycheck-checker-error-threshold’ to
change the threshold or ‘C-u C-c ! x’ to re-enable the checker.

How to stop this window from opening? It is extremely obtrusive and annoying.

0

I do not have a better answer than this one: Use M-x customize-variable RET flycheck-checker-error-threshold to change the threshold. Mine is currently set to 400.

If someone has a better solution, I gladly remove this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.