9

When running list-packages in emacs on an up-to-date Debian Buster (10.6) I get the following error:

error in process sentinel: Error retrieving: https://stable.melpa.org/packages/archive-contents "incomprehensible buffer"

The exact version of the emacs package is 1:26.1+1-3.2+deb10u1. When using wget on that URL and looking at the downloaded file it looks like a valid e-lisp data structure to me.

This has been working in the past and works fine in the MacPorts emacs package version 27.1_5.

8

I had the same problem. Solved it by adding the following to init.el

    (setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3")
2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.