3

Currently I have the following init file to install and use use-package:

;; Package.el
(require 'package)
(package-initialize)
(setq package-enable-at-startup nil) 
(add-to-list 'package-archives  '("melpa" . "https://melpa.org/packages/"))

;; use-package
(unless (package-installed-p 'use-package)
  (package-refresh-contents)
  (package-install 'use-package))


;; use use-package
;; (use-package some-pack :ensure another-pack)  

Not all packages work with use-package, so I am extending it with quelpa. I need to install both the extension and quelpa itself. It seeems it could work like this:

(use-package quelpa-use-package
  :ensure t
  :init
  (setq quelpa-update-melpa-p nil)
  (setq quelpa-self-upgrade-p nil))

If I start my init file in this way, I do not get any error. However, when I try to add a git package, such as matrix-client:

(use-package matrix-client
  :quelpa (matrix-client :fetcher github :repo "alphapapa/matrix-client.el"
                         :files (:defaults "logo.png" "matrix-client-standalone.el.sh")))

I get at startup:

Error (use-package): Failed to parse package matrix-client: use-package: Unrecognized keyword: :quelpa

How can I install quelpa-use-package from use-package? (If I can)

1

I got the same error: "use-package: Unrecognized keyword: :quelpa" with emacs 26.3. And after I:

  • Verified packages installed: use-package, quelpa, quelpa-use-package ( I installed them all by M-X package-install)
  • Add below to my .emacs file
(require 'use-package)
(require 'quelpa-use-package)

The command (which was similar to your command) worked correctly:

(use-package gdb-mi :quelpa (gdb-mi :fetcher git
  :url "https://github.com/weirdNox/emacs-gdb.git"
  :files ("*.el" "*.c" "*.h" "Makefile"))
  :init
  (fmakunbound 'gdb)
  (fmakunbound 'gdb-enable-debug))

May this help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.