1

I'm using the emacs package on debian 10 and the dead keys for typing accents on characters (for instance, á) are no longer working. WHen I type the dead key, some kind of tiny window or artifact gets displayed, and then when I type the character itself the artifact disappears but nothing gets typed. I think I must have unwittingly toggled some option, because I haven't changed anything in locale,etc and all other applications except emacs work well re typing of accents. What can I do to get dead keys working again? Thanks

1

I have the same problem.

Reproduced with emacs -Q, version GNU Emacs 27.1 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.23, cairo version 1.16.0)

A workaround is disabling the input methods, as described in https://www.emacswiki.org/emacs/DeadKeys.

Namely the option of unsetting the XMODIFIERS environment variable works for me: env XMODIFIERS= emacs.

Launching emacs like this, the pop-up does not show and the XKB-defined dead keys produced the combined characters. I believe that this means giving up on all the fancy input method facilities provided by emacs, but I don't use those anyways.

The first workaround described in the Emacs Wiki, (require 'iso-transl), does not do anything for me.

1
  • Thanks very much. Your solution worked for me.
    – korppu73
    Jan 28 at 6:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.