0

I have my org-agenda to start on a Sunday. Hence I have this code in my .emacs file:

(setq org-agenda-start-on-weekday 0)

org-agenda opens with the cursor on the current day of the week.

If I press "f" to move forward a week, Emacs will move the calendar forward from the place of the cursor. Hence if the cursor is on a Friday, it will move forward to the next Friday. This means that part of my agenda is not visible and I have to scroll up or press C-Home. I would always like the whole agenda to be visible regardless of where the cursor rests.

See the accompanying pictures:

https://drive.google.com/drive/folders/1-pVsp7pAkPsVQCXn49mDw0c-bUS5Vef0?usp=sharing

6
  • My org-agenda org-agenda window always open to the full height of the screen. – Raoul Comninos Dec 12 '20 at 16:06
  • I don't understand what you mean: with that setting, my weekly agenda goes from 2020-12-06 to 2020-12-12. If I press f, it goes from 2020-12-13 to 2020-12-19, no matter where the cursor is (but on whichever day it is on for this week, that's the day it is going to end up at for next week). Scrolling up just takes me to the beginning of the relevant week. Is that not what you are getting? – NickD Dec 12 '20 at 18:11
  • 1
    If not, you might want to try starting with emacs -Q -l minimal-init.el. The minimal init should just load org and do the setting above. If that works to your satisfaction, there is something in your real init file causing the problem: bisect it to find it. – NickD Dec 12 '20 at 18:14
  • 1
    I cannot reproduce the behavior you show in your second image: for me the whole next week is shown. You might want to post the version of Org mode you are using: maybe it has a bug. But I think it is more likely that there is something in your init that causes this: you might want to try the emacs -Q with a minimal init file and see if that works. – NickD Dec 12 '20 at 18:54
  • 1
    Upgrading to the latest version of Org mode version 9.4.1 fixed the problem. The bug is in version 9.3 which comes bundled with Emacs 27.1. Thanks so much @NickD – Raoul Comninos Dec 12 '20 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.