0

After having moved to an upgraded machine, I am now facing problems with my org-mode setup, specifically that org-id-find now returns nil for IDs that do exists in my org files. This breaks some of my functions (where it is used in conjunction with org-with-point-at), as they are unable to find the correct headings.

On emacs 24.5.1/org-mode 8.2.10, org-id-find returns (file-name . position) as it should, but on emacs 25.2.2/org-mode 9.1.6, org-id-find returns nil. The configuration files are the same.

org-id-track-globally is set to t, and I can see in *Messages* that files are searched for IDs. The file system in which my org files are located are the same on both machines (it's mounted from a central file server with NFS). org-id-locations-file is set and I have tried running org-id-update-id-locations to no avail.

I haven't been able to find any explantion for this behaviour. Anyone experienced anything similar?

3
  • Although I don't use them, I'd say you'll need to define the variable which tell what files are going to be tracked and redo the tracking file (?) using org-id-update-id-locations. – Muihlinn Dec 15 '20 at 14:12
  • @Muihlinn is correct I believe: do C-h v org-id-locations-file for more info. If the files are in the same locations in the new filesystem, you should be able to just copy that file from the old machine to the new machine and reuse it. Otherwise, you will have to reconstruct it. – NickD Dec 15 '20 at 17:18
  • I forgot to mention that the file system in which my org files are located is on NFS, so the locations are the same on both machines. And org-id-locaitons-file is set and I have already tried with org-id-update-id-locations to no avail. I have updated my question. – Thomas Espe Dec 16 '20 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.