0

I have a setup with three different accounts on macos, switching works e.g. with the context setup and I am able to send emails with each one of them. An account is a ms exchange account which uses davmail, the other is a gmail account and the third a gmx. Though only with the davmail account I am able to read the mails correctly in the macos mail.app.

When sending with the two other accounts I have a wrong display of german umlaute, e.g.

Gau=C3=9Fstra=C3=9Fe

where it should be

Gaußstraße

in addition the mime-version info is sent and shown by the mail.app as well, e.g. see below (where you also can see that the signature separator is written as "--=20":

--text follows this line--
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable

--=20

Update: I also get

--text follows this line--
Vielen Dank und viele =?utf-8?B?R3LDvMOfZSE=?=
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii

when it should say:

Vielen Dank und viele Grüße

No, I see a different charset!? Not sure, if this is relevant...

Do you have an idea what is going wrong? This is the setting which I have for gmail

                (smtpmail-starttls-credentials . (("smtp.gmail.com" 587 nil nil)))
                (smtpmail-auth-credentials . (expand-file-name "~/.authinfo.gpg"))
                (smtpmail-default-smtp-server . "smtp.gmail.com")
                (smtpmail-smtp-server . "smtp.gmail.com")
                (smtpmail-smtp-service . 587)
                (smtpmail-stream-type . starttls)
                (mu4e-sent-messages-behavior . delete)

Do you need more information about the setup for each account?

Here is an update and further information:

  • I am using spacemacs with emacs 28.0.50 (and I tested it with 27) mu 1.4.13 on macos

Using gnus the sending works fine with these settings in .gnus.el

(setq send-mail-function 'smtpmail-send-it) 
(setq smtpmail-smtp-server "smtp.gmail.com") 
(setq smtpmail-smtp-service 587) 

This short settings does not result in correct mails with mu4e.

When looking in the drafts folder with the mail.app client on my gmail account, I see the message in a correct way.

I tried also plenty of other things for setting the encoding... the problem is however that I do not not know in which direction I have to look further

e.g. I tried something like:

(set-default-coding-systems 'utf-8-unix)
(setq mm-coding-system-priorities '(iso-latin-1 utf-8))

and similar settings without success.

Next Update using msmtp:

I was testing the sending with msmtp for all three accounts using mu4e and the context setup. Sending itself works again, but only the davmail account sends correct emails. The other accounts (one is gmail) results in the same problem as above.

And testing a plain file with msmtp like this

cat test.mail | msmtp -a default <username>@domain.com

with something like

To: username@domain.com
From: username@gmail.com
Subject: A test

Vielen Dank und viele Grüße

works great with gmail as well... but the buffer from mu4e gets sent somehow in a wrong way!?

The plain file which I sent in a correct way was encoded as 'unix'; the standard way which mu4e seems to use is 'utf-8' (at least this is chown in the modeline); chaning it to 'unix' as well does not result in a correct mail!?

msmtp with mutt

Tested it and it works as well; just for the record; there I have set:

set send_charset = "utf-8:iso-8859-1:us-ascii"
set charset = "utf-8"
2
  • maybe, this question is better placed as an issue on github for mu4e!? – Fabian Dec 26 '20 at 20:41
  • excuse me for the many updates... – Fabian Dec 27 '20 at 12:38
0

solved

I had probably an old mutt setting in my emacs config which caused the mentioned behavior. Sorry for the trouble...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.