1

I have problems upgrading packages coming from melpa:

When executing list-package with "https://melpa.org/packages/" in the package-archives I get the following in the *Messages* buffer:

Using a proxy for https...
gnutls.c: [0] (Emacs) Received alert:  Handshake failed
gnutls.el: (err=[-12] A TLS fatal alert has been received.) boot: (:priority NORMAL :hostname melpa.org :loglevel 0 :min-prime-bits nil :trustfiles (/etc/pki/tls/certs/ca-bundle.crt) :crlfiles nil :keylist nil :verify-flags nil :verify-error nil :callbacks nil)
error in process filter: End of file during parsing

I guess this is an SSL/TLS issue, so I checked:

  1. I had Emacs compile with the default gnutls support.
  2. I have set (setq package-check-signature nil) before (package-initialize)

Does Emacs needs to know some certificates for melpa?

More environment info:

  • Emacs is 27.1 compiled from source.
  • OS is CentOS 6. (Cannot change the OS.)
  • Connection is via a local proxy (which does not need any authentication).
8
  • Consider retrying without the proxy. – wasamasa Dec 23 '20 at 8:10
  • @wasamasa I have to use the proxy to connect the Internet, without I'm stuck in the company-wide Intranet.. – halloleo Dec 23 '20 at 10:56
  • Yes, so consider using that machine outside the company internet, like by disabling all VPN software and using a mobile hotspot. – wasamasa Dec 23 '20 at 17:06
  • @wasamasa Unfortunately I cannot connect the machine to another network due to security restrictions. I'm looking for an in-Emacs solution. – halloleo Dec 23 '20 at 21:36
  • I'm suggesting you possible ideas for debugging. Failing to change the network settings you could attempt to reproduce the environment inside Docker or so. Another thing worth trying is to see whether you get the same error when browsing a HTTPS site in M-x eww to see if it's specific to MELPA or not. – wasamasa Dec 23 '20 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.