0

I am following the instructions here for how to customize importmagic.

I have the following in my init.el:

(setq importmagic-configuration-style-alist '((multiline . backslash)
                                              (max_columns . 1000)))

And the following in my setup.cfg

[importmagic]
multiline = 'backslash'
max_columns = 1000
indent_with_tabs = 0

And yet I call importmagic-fix-symbol-at-point, I see it use parentheses instead of backslash and it does it at 79 spaces.

(This is especially troublesome because it seems to often introduce a syntax error when it does it---leaving a trailing comma at the end with

from my.very.long.string.of.package.imports.and.myimport import (,  # I fail because of this terminal comma
  whatever, another
)

This means that every time I use importmagic to fix one import, I need to undo all the syntax errors it introduces in all my other imports. So I'm trying to just set the max_columns so high it doesn't try. )

Anyway, what is the right syntax to actually change these settings in which file? Is my setq syntax incorrect somehow?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.