0

I has Emacs 25.3

emacs -version
GNU Emacs 25.3.2
Copyright (C) 2017 Free Software Foundation, Inc.
GNU Emacs comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GNU Emacs
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.

I want to install on my Linux Mint 19.6 the Git. So I try this:

sudo apt install git

But I get error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 emacs27 : Depends: emacs27-common but it is not going to be installed
 git : Depends: git-man (> 1:2.29.2) but 1:2.27.0-1~ppa0~ubuntu18.04.1 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I always get this error if I want to install any package.

E.g.

sudo apt-get install libcurl4-openssl-dev 



Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 emacs27 : Depends: emacs27-common but it is not going to be installed
 libcurl4-openssl-dev : Depends: libcurl4 (= 7.58.0-2ubuntu3.12) but 7.58.0-2ubuntu3.9 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
2
  • Is this really an Emacs question? – Drew Dec 26 '20 at 19:08
  • You should ask this question on the Unix/Linux SE. – NickD Feb 24 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.