0

I tried to specify :tstart and :tend in my clocktable block according to the official documentation, e.g.

#+BEGIN: clocktable :scope agenda :maxlevel 6 :stepskip0 t :fileskip0 t :compact t :link t :tstart "<2020-12-27 Sun 06:00>" :tend "<2020-12-28 Mon 06:00>"

I also tried a minimum example of #+BEGIN: clocktable :tstart "<2020-12-26 Sun 06:00>" :tend "<2020-12-27 Mon 06:00>"

However, only the clock entries from today seem to be produced. The :tstart and :tend are always ignored, for whatever reason.

1

I dug around a bit more, and just before I was about to post the question, I realized that I have

  (setq org-clocktable-defaults
        '(:scope agenda :maxlevel 6 :stepskip0 t :fileskip0 t :compact t :block today))

I didn't fully understand org-clocktable-defaults. I thought it would be the defaults copied to the #+BEGIN: clocktable part after you create a new clocktable in any buffer, but apparently this is not how it works. Instead, everything specified here will serve as the default values unless you explicitly override them. In this case, :block today is always taking effect, thus overriding the :tstart and :tend options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.