0

I updated spacemacs and all layers/ packages today. Since then, when in c++-mode at the top of my buffers the current file and its parent folders are displayed, as shown in the image.

I'm fine with the functionality but clearly there are some icons missing (as evidenced by the small squares containing "EsCC"). Where must I supply them?

This line seems to be a feature of c++ layer as it also displays c++ - specific info like class names and namespaces.

Here are all my layers, in case it helps:

 go
 systemd
 javascript
 rust
 html
 yaml
 vimscript
 csv
 markdown
 auto-completion
 (python :variables python-backend 'anaconda)
 octave
 better-defaults
 emacs-lisp
 helm
 (lsp :variables
      lsp-ui-doc-enable t
      lsp-ui-sideline-enable t)
 (c-c++ :variables
    c-c++-backend 'lsp-clangd
  c-c++-lsp-cache-dir ".cache"
  c-c++-enable-clang-support t
  clang-format-style "file")
  (cmake :variables
        cmake-backend 'lsp
        cmake-enable-cmake-ide-support t)

 multiple-cursors
 spell-checking
 syntax-checking
 latex
 julia
 restructuredtext
 json
 

Top part of my emacs buffer

2
  • You're posing two questions, it seems. Please pose them as separate posts (please remove one from here). Thx. – Drew Dec 28 '20 at 21:37
  • Will do, thanks for letting me know. – Eike Dec 28 '20 at 22:01
1

After ignoring the issue and just working on my project I realized that it must be part of the c++ layer.

The solution for me is: You need to install additional fonts. What works, is installing all the fonts in the github repo of all-the-icons.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.