2

If I'm working on one project and I switch over to a buffer from another the default behavior of Doom Emacs seems to be to open the new buffer in a new workspace (when workspaces are enabled). I want the default behavior to be to open it in the current workspace, but I don't want to disable workspace functionality in general. Is there a good way to do this?

After more research this seems to be an interaction between persp-mode and projectile.

0

There is a variable called +workspaces-on-switch-project-behavior. Its documentation states

Controls the behavior of workspaces when switching to a new project.

Can be one of the following:

t           Always create a new workspace for the project
'non-empty  Only create a new workspace if the current one already has buffers
            associated with it.
nil         Never create a new workspace on project switch.

Setting it to nil gives me the desired behavior, which is that a new workspace is not created when switching projects.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.