0

Flyspell sets the keys C-. and C-,. I prefer to have other binds living on these keys. I would have assumed locally setting keys in flyspell-mode-hook would have fixed this:

    (add-hook 'flyspell-mode-hook
                        (lambda () ;; flyspell sets these keys. Bad flyspell.
                            (local-set-key (kbd "C-,") 'ivy-switch-buffer)
                            (local-set-key (kbd "C-.") 'other-window)
                            ))

Unfortunately, it doesn't. I found this other post, but there is no flyspell-auto-correct-binding equivalent for these two keys, so I'm stumped. https://stackoverflow.com/questions/6617507/setting-shortcuts-keys-in-specific-modes-in-emacs-e-g-ido

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.