0

I have been using emacs for many years, but from version 26 ... there is a mess with server as I have to type emacsclient in place of simply emacs. Going worse with 27.

From 26 I haven't found a way to disable server mode ... From 27 emacsclient allows me to open only one session at a time ... I received message showing type CTRL # when you have finished ... while the file I try to open in another shell is asking me to Wait.

It's not fine at all.

How can I get the old behaviour ? I don't need server mode by default. I just need that emacs -nw opens my file without messing ...

5
  • 2
    I haven't noticed any change in the behaviour. Can you describe in more detail what you expect and how the current behaviour differs to it? – choroba Jan 4 at 18:42
  • When I try to open file with "emacs myfile", it's getting back to command line. I can see a process emacs daemon running. Then I must open my file using emacsclient. From 27.1, i can open only one emacsclient at once. The second one asks me to wait. I want to type emacs myfile ... it' s opening without talking server and so on. The old behaviour ... – jmary Jan 4 at 18:52
  • 1
    That's not what I see. What does type emacs output? – choroba Jan 4 at 19:11
  • Please put all clarifications into the question itself. Comments can be deleted at any time. – Drew Jan 4 at 22:05
  • Do you see the same problem if you use switch Q when you run emacs or emacsclient? If not, bisect your init file to find the culprit. – Drew Jan 4 at 22:06
1

Solution (it's silly) : Oh_my_zsh defined an alias launching the daemon mode by default. I had to disable the call to emacs plugin in my .zshrc

See https://github.com/ohmyzsh/ohmyzsh/tree/master/plugins/emacs for details.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.