1

The spacemacs LSP layer documentation says:

Enabling this layer will set the used backend for all supported languages to LSP unless you explicitly set a specific backend for the language.

I find this a problem because emacs often prompts me to install a language server (occasionally even trapping me in the minibuffer because of some bug), but I rarely feel the need to use LSP for a given language. So if I want to use LSP even for one language, I have to configure it off for every other, file type by file type (that includes e.g. things like JSON files). That seems like a never-ending task.

Is there some way around this so that I can explicitly enable (whitelist) use of LSP instead of disable it (blacklist) for particular languages?

3
  • In the meantime, mind telling me how you've even managed to disable it per-language?
    – Didier A.
    Mar 25 at 0:24
  • @DidierA. For python, in my dotspacemacs-configuration-layers I have: (python :variables python-backend 'nope) (the real values are 'anaconda and 'lsp) Apr 21 at 17:56
  • @DidierA. For json, in my dotspacemacs/user-config I have: (setq json-backend 'company-json) Apr 21 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.